Running exe files through sys

I need to run an exe file at the end of a process, but it seems that SSDpauses while the exe file is running? As soon as I manually close the exe file the SSD process continues. Is there any way around this? I need the exe file and SSD to run simultaneously.

*** Stop : Program TEMPLATE : Generate print.txt
*** System Command: Close_SOFiSTiK_Prompt.exe 

This is where SSD pauses. As soon as I close the .exe file manually, SSD continues as it should

*** System Command: C:\Program Files\SOFiSTiK\2020\SOFiSTiK 2020\ursula.exe TUX_STE_014.plb -printto:"Bluebeam PDF" -page:all

*** End of Calculation!

If I run the exe file manually outside SSD, and run my SSD process afterwards everything works as intended. Therefore, in order to check the +sys command, I wanted to run a commercial software just for debugging. As such I’m trying to run Adobe through +sys command, but apparently the exe file needs to be in the parent directory?

+sys C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe

yields following error message:


Am I missing some syntax in order to make this work?

  • You can specify whether WPS should continue calculation or wait until the started process is finished:
    +sys wait Waits until the subprocess/command is finished (default)
    +sys nowait Calls the command and continues immediately
    Wait is normally used if the subprocess generates results that are needed in further calculation

  • You can use programs in other directories but the windows command line syntax still applies, i.e. no spaces or use “”:
    +sys "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe"

ah perfect, nowait solves the issue the first issue :slight_smile:

But I have tried wrapping +sys "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe" into every conceivable constellation of ' / " / "' but I still get the same error message. :confused:
If I run the same directory path in CMD " does the trick, but SSD doesn’t accept this.

Seems like the wait/nowait specifier is needed, the two below work for me.
+sys wait "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe"
+sys nowait "C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe"

Perfect, thank you very much!