Error: "CDBase is in use by other users"


I get the error massage “CDBase is in use by other users”.

I read in another thread “Fehlermeldung CDBase” that it could be fixed by cleaning the locks on the .cdb file. This has worked before when I got the message.
However now it seems to have no effect when trying. Any other tips?

Hello Jonas,

According to the message I assume that you are working in a local folder? Or are the project files stored on a cloud/server? If so, copy the files to a local folder and edit them there.

So you tried to clean the lock files by right clicking on the .cdb?
Can you describe your problem in a little more detail?

  1. Can you open the .sofistik with the SSD?
  2. Does the message appear in SSD or SOFiPLUS(-X)?

If you can’t solve the problem, you can send me the files and I’ll take a look.

Best regards
Frederik Höller
Your SOFiSTiK Support Team

Hi Frederik,

Thanks for the reply.

Yes I work through mainly through OneDrive, but tried copying the files to the desktop when I got the problem. Unfortunately it didn’t help.
I got the problem as I stopped a calculation mid calculation. When trying to run it again I got the error message shown in my first message.

  1. No I can not open the .sofistik file through SSD, I get the same error message as in the first message. However sometimes I can open the project and see/open my task tree, but i can not run it without getting the error message. So I copied all my Teddy code and made a new project and is now working through that, so we are no longer in a rush to fix this. Though it would be nice to know what went wrong so I don’t do it again, or can fix it if the problem should arrive.

  2. It appears in SSD. I have not tried SOFiPLUS(-X).

Yes I can send it to you if you want to have a look for yourself. How should I do that? Attach it in a message here? Or is there another way?

Ok, we don’t advise working on OneDrive as it leads to longer calculation times and increases the risk of file locking. So please copy the file to your local computer in the morning and save the files again to the cloud after the day.

So have you tried to clean the locks?

If that doesn’t work, you can try saving the .sofistik and the .dwg to a new local folder and starting from there.

If this doesn’t work as well, please send me the files here in the forum (add them to the message, I have updated your user level).

Best regards
Frederik Höller
Your SOFiSTiK Support Team

Oh okay I see. Good to know.

Yes I tried cleaning the locks. It seems that when I clean the locks I’m able to open the project and see the task tree. But when I try to calculate anything I get the error message.

Here are the .dwg and .sofistik files I am not able to upload the .cdb file. Is there a better way to share projects, than sharing these three files? I’m still fairly new to SOFiSTiK

BasinSection.dwg (256.1 KB)
BasinSection.sofistik (1.1 MB)

So have you tried the second step?

Because when I open the SSD, export the system from SOFiPLUS(-X) and calculate the tasks, I don’t get an error message…

Yes I did but only by copying the .cdb file also. Didn’t think I could run it without the .cdb file but I guess it just creates a new .cdb, when it isn’t there to start with.
But it works now when only using the .dwg and .sofistik files. It was just the .cdb file that was somehow corrupted.

Thanks for the help!

1 Like

That’s correct :slight_smile:.
If you export the system from SOFiPLUS(-X), a new .cdb will be created.