Wingraf Toolbar

Hi all, I think this bug has been around for a long time, any chance to reset the toolbars without manually dragging them all back into place?

Hello,

I don’t know any task to order the toolbars in a specific way. But you can drag them to the desired position and close WinGraf. If you open the program again, the icons should be at their last position.

Yours sincerely
SOFiSTiK Support Team

Hello,

Isn’t there be a “default” layout to which I can reset? Like the layout which is there when it is installed?

It happens from time to time that I open wingraf and it looks like in the screenshot, it is really annoying then to drag them item by item back to place.

Thanks!
Daniel

Hello,

I am sorry, but there is no official function in WinGraf to set the “default” layout.
You can reset the WinGraf setings by clearing the registry. But I would not recommend this workflow for inexperienced user.

  1. Therefor open regedit on your computer and delete the following folder:
    HKEY_CURRENT_USER\Software\SOFiSTiK\2020\wingraf
    Now WinGraf will be opened with the default settings.
  2. Drag the toolbars and close WinGraf.
  3. Open the registry path again and export the “wingraf” folder.
  4. Everytime your icons are mixed up, close WinGraf and open the exported registry file
  5. Open WinGraf again and the toolbars should be in the preset layout

Hello,

thanks, that sounds reasonable. Unfortunately I do not have this entry in the registry (neither for CURRENT_USER nor for LOCAL_MACHINE). There is no wingraf foulder. Any idea where else to look?

Thanks
Daniel

Could it be that SOFiSTiK was not installed on your user, but on another user on your computer? Normaly there has to be a wingraf folder to save the settings.

I’m pretty sure it has been installed as administrator. But there is nothing in the registry under current user when I log in as administrator either.