Steel sections not visible in the project navigation


I’ve installed SSD 2023 and i have a strange problem: when i create a new cross section with “New standard section”, followed by “Steel profile”, the selected steel profile doesn’t shows up under the Cross Sections. Other sections (eg concrete sections or cable sections) are functioning without any problem.
Any idea?

Hello Mr Willems

This is indeed a strange behaviour. I tried to reproduce your descirbed problem, but with no success.
Just to be clear, you can’t create a standard steel section in the SSD as show in the picture bellow?

They sent my colleague a test project, but even there I can make a standard HEA-100 steel profile…
Just to check, you are working with an educational licence and the latest service packs?

Best regards
Frederik Höller
Your SOFiSTiK Support Team

Hi Frederik,

That is exactly the problem I have. All sections seems to work, except the steel sections are a problem.

I have a educational license and this is the version:

I have this problem also with the previous versions of Sofistik.

I already tried to change the dpi settings of my display (since I was thinking of a hatdware problem) but that didn’t solve the problem either.

Thank you,


Have you checked whether the cross-section can be visualised in the result viewer?

Result > Create a new Graphic > Cross section overview

Does this behaviour appear when working with:

  • SOFiPLUS(-X)
  • another design code (not NBN)

Here I send you a modified SSD project. Try to create a new steel section in this project.
Test2.sofistik (31.6 KB)

Apart from that, have you tried to reinstal the SSD?

The modified project works perfect. I can see the steel section you’ve mcreatde and, in this modified project, i can create new steel sections by myself.
Changing the design code (i’ve used EC and DIN allready) doesn’t solve the problem. Also, using a different input engine (Rhino, Sofiplus) doesn’t solve the problem either.

Sorry, i forgot the mention that the created (but invisible) steel section doesn’t appear in the result viewer.

OK so I don’t think this problem can be solved without seeing all of the log files. Please send us your project files via the SOFiSTiK Application Manager.

Done. It seems to be hardware related. Student without Nvidia graphical cords don’t have this problem…

1 Like