Instability Error when using Cross-Section Interpolation


I am working on a project in Rhino/Grasshopper and wanted to implement an interpolated cross-section for one of my elements. I defined the a start and end cross-section and input them using a “.” (i.e. “10.20”). This worked perfectly and produced an interpolated section between the start and end of the structural line. My problem is that when I went to calculate all of my load cases, every single program failed and immediately reported a system instability. When I switch my interpolated section back to a normal section, then the program calculates without errors.

Am I missing something? Is there a setting I need to change in the ASE programs for the load cases?

Any help would be appreciated.



This shouldn’t be a problem in ASE, but in your meshing/modelling.

Hard to say what the problem is with that little info.
Maybe post the teddy files produced by grasshopper, so that it is possible to generate the system and see what the problem is.

Thanks for the reply.

I actually gave up on the interpolated cross-section problem last week but just ran into another issue which seems to be related. Today, I wanted to define a cross-section based off of a typical W-Shape but with one side closed (i.e. welding in a steel plate on one side). I created this section without any problems using the SECT command with PROF and PLAT. When I visually check the geometry after SOFIMSHC, everything looks great (just like it did when I defined the interpolated sections last week). However, when I try to calculate a load case in ASE, I immediately get an instability error. The type of error I’m getting seems identical to that when I was using the interpolated sections, so I get the feeling they have the same root cause.

I created a very simple system (a simply supported beam) to see if the problem persists and if I can recreate it here for you to look at. Unfortunately, this model didn’t produce any errors, so it doesn’t really help me for my larger project, but I’ll post the simple model here anyways.

The only differences between my model and this simple system is that my model has cable and membrane elements, which is why I’m calculating the system using TH3. I also used to have SYST NMAT YES in my ASE programs (because of the QUAD elements), but I removed this in the simple model. Aside from the complexity of my larger model, these are the only two differences between how I set up the Teddy files, and like I said, as soon as I swap out the cross-section for a per-defined profile, the system calculates without any problems.

I’ve included a standard section, my custom section, and an interpolated section in my AQUA program for you to compare. If you want to run the interpolated section, don’t forget to change “10” to “10.11” in the SOFIMSHC program and run the additional AQUA program afterwards.

If you can already see what I’m doing wrong, let me know. I might make a new simple model tomorrow with a membrane element to see if I can recreate the error there.



Special_Profile_Test_model.dat (12.6 KB)

I decided to make a simple model that more closely represents my full model.

This model almost exactly represents the geometry in my large model, but still does not produce any errors. I’m very confused now because the only real difference between this model and the full model is that this “roof” element is integrated into a larger steel frame so that the edge elements are not directly supported.



Special_Profile_Test_v02_model.dat (18.1 KB)

Hi Again,

I found the cause of the problem, and it’s related to SYST NMAT. I turned this off (or removed it) in my simplified models, which is why the programs calculated without any issues. I meant to turn NMAT back on in my second model to better represent my full model, but I forgot. If you go back into the second model and remove the comment before NMAT in the 200 LC (for example), you will be able to reproduce my original problem.

I’ve decided to run my large model without NMAT, but I would still be very interested if you know why my custom section and interpolated section both don’t work with this setting activated. Any help would be greatly appreciated.